Issues with IPRO Cloud Canada

Incident Report for IPRO

Resolved

This incident has been resolved.
Posted May 18, 2026 - 15:49 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 11:39 MST

Investigating

We are currently investigating an issue affecting environments hosted in IPRO Cloud Canada. Users may experience issues accessing hosted resources while we work to restore service.
Posted May 16, 2026 - 22:44 MST
This incident affected: IPRO Cloud - CA and IPRO Services Environment - Canada.