Access issues with Open Discovery
Incident Report for IPRO
Resolved
This issue has been resolved.
Posted Sep 22, 2023 - 09:08 MST
Investigating
We are currently investigating an issue with accessing Open Discovery cases in one of our hosted Cloud Environments.
Posted Sep 22, 2023 - 09:04 MST
This incident affected: IPRO Services Environment - USA.