CloudFiles Currently Inaccessible
Incident Report for IPRO
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 17:15 MST
Investigating
We are currently investigating this issue. Access to the Cloud Portal (Citrix) is still operational. This is currently affecting CloudFiles.iprotech.com and FTP Transfers
Posted Feb 15, 2024 - 16:26 MST
This incident affected: IPRO Cloud Login Portal.