MediaShuttle Issues
Incident Report for IPRO
Resolved
This issue has been resolved.

If you encounter any further issues please reach out to services@ipro.com.
Posted Dec 06, 2023 - 16:34 MST
Investigating
We are currently investigating an issue with MediaShuttle portals.
Posted Dec 06, 2023 - 16:27 MST
This incident affected: IPRO Cloud - US.